RODIN Voice - call issues

Incident Report for RODIN Business Solutions Status

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 15:32 AEST

Monitoring

We are seeing reports that this issue has now been resolved and are monitoring for stability
Posted Aug 10, 2026 - 14:29 AEST

Identified

We have identified an issue with calls via the Xelion platform and are currently investigating with the provider
Posted Aug 10, 2026 - 14:09 AEST
This incident affected: RODIN Voice.