Potential NBN carrier issues

Incident Report for RODIN Business Solutions Status

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 14:41 AEST

Investigating

We are receiving reports of NBN carrier outages south of Wollongong - affected services from Dapto down to Nowra. We'll provide updates as they become available
Posted Aug 13, 2025 - 13:09 AEST