RODIN VOICE - Xelion Call Issues
Incident Report for RODIN Business Solutions Status
Resolved
Issue has been resolved - calls have been tested OK. RODIN will provide a status report when it becomes available
Posted Jan 19, 2024 - 08:40 AEDT
Investigating
We have identified an issue this morning with RODIN Voice customers using Xelion phone systems - some customers may be impacted by what appears to be an upstream provider incident. Engineers are actively investigating and working on a resolution.
Posted Jan 19, 2024 - 08:20 AEDT
This incident affected: RODIN Voice.