Exchange Online Outage
Incident Report for RODIN Business Solutions Status
Resolved
Microsoft have updated advisory EX522020 confirming this issue is now resolved after re-routing traffic to alternate infrastructure
Posted Mar 02, 2023 - 09:05 AEDT
Identified
Microsoft have reported issues for APAC customers accessing exchange online and some customers are receiving a "550 5.4.1 Recipient address rejected: Access denied" when sending emails.
Microsoft are investigating this and updates can be found here:
https://twitter.com/MSFT365Status/status/1630983423694077979?t=qK8GrhRunoa8jXfqkSVCag&s=19
Posted Mar 02, 2023 - 06:43 AEDT
This incident affected: Microsoft Office 365.