Xelion - Unplanned outage
Incident Report for RODIN Business Solutions Status
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 17:24 AEDT
Monitoring
Xelion root cause has been identified, and now operational. We are continuing to monitor for stability.
Posted Nov 18, 2024 - 14:09 AEDT
Investigating
We are currently investigating inbound and outbound call issues with Xelion. Further updates to come.
Posted Nov 18, 2024 - 13:35 AEDT
This incident affected: RODIN Voice.