Users may be unable to access Microsoft Power App
Incident Report for RODIN Business Solutions Status
Resolved
Final status and update from Microsoft: After an extended period of monitoring, we've confirmed that impact has been resolved and that the service has fully recovered. Additionally, we've determined the isolated issue within a small section of the European infrastructure is also resolved.
Posted Nov 17, 2023 - 07:51 AEDT
Update
Latest update from Microsoft: 16 November 2023 at 10:00 pm AEDT
More info: Additionally, some users may also be experiencing the following issues:

- Runtime failures when playing apps and creating connections
- Integration with SharePoint Online would not function as expected

Current status: We're continuing to monitor an increase in service availability as the rollback progresses further. In parallel, we're expediting the rollback process to deliver a quicker resolution for the remaining affected infrastructure.
Posted Nov 16, 2023 - 22:10 AEDT
Update
Current status: Microsoft have identified a recent API update, intended to address a separate issue, that may be causing the impact. They are reverting the API update while monitoring service health and continuing to investigate possible causes.
Posted Nov 16, 2023 - 17:26 AEDT
Update
More info: Users may see the following error messages when attempting to load Power Apps:
- There was no response from the server.
- The data did not load correctly. Please try again.

Current status: We've identified that infrastructure responsible for Power App functionality isn't processing traffic as efficiently as expected. We're reviewing potential options for this unexpected performance, including recently deployed updates.

Scope of impact: Our investigation currently indicates that users located in Australia and Japan are most impacted.
Posted Nov 16, 2023 - 16:50 AEDT
Identified
User impact: Users may be unable to access Microsoft Power Apps.
Current status: We're investigating a potential issue and checking for impact.
Further updates from Microsoft will be posted below as they are provided.
Posted Nov 16, 2023 - 16:34 AEDT
This incident affected: Microsoft Office 365.